Script Untuk Update IP DynDNS ( Mikrotik ROS 6.x )

dyn-logoScript ini berfungsi untuk melakukan update IP untuk layanan dynamic DNS di DynDNS.com. Dynamic DNS sendiri adalah layanan yang memberikan kita kemudahan untuk melakukan penterjemahan dari sebuah domain name menjadi IP address yang selalu berubah-ubah pada host ( dinamik IP ). Sehingga dengan adanya layanan ini kita tidak perlu repot menghafal IP address setiap kali berubah, cukup hafalkan saja hostname yang kita dapat dari DynDNS. Oya, perlu diketahui bahwa saat ini DynDNS tidak lagi menyediakan layanan gratis untuk pendaftaran akun baru, namun karena saya masih menggunakan akun lama maka masih bisa menggunakan layanan dynamic DNS hingga 2 hostname.

Lanjut ke script untuk update IP Adress hostname DynDNS, script ini saya gunakan pada Mikrotik RB450G dengan RouterOS ver 6.9 ( ROS 6.x ) :

:global ddnsuser "userdyndns"
:global ddnspass "passworddyndns"
:global theinterface "pppoe-out1"
:global ddnshost hostname.dyndns.org
:global ipddns [:resolve $ddnshost];
:global ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
:if ([ :typeof $ipfresh ] = nil ) do={
:log info ("dynDNS: $theinterface tidak memiliki IP Address.")
} else={
:for i from=( [:len $ipfresh] - 1) to=0 do={
:if ( [:pick $ipfresh $i] = "/") do={
:set ipfresh [:pick $ipfresh 0 $i];
}
}
:if ($ipddns != $ipfresh) do={
:log info ("dynDNS: IP-DynDNS $theinterface = $ipddns")
:log info ("dynDNS: IP-Fresh $theinterface = $ipfresh")
:log info "dynDNS: Pembaharuan diperlukan, Meminta Update IP ke DynDNS...!"
:global str "/nic/update\?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
/tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
:delay 1
:global str [/file find name="DynDNS.$ddnshost"];
/file remove $str
:global ipddns $ipfresh
:log info "dynDNS: IP $theinterface berhasil diperbaharui menjadi $ipfresh!"
}
}

Selanjutnya anda buatkan scheduler, agar script bisa di jalankan setiap menit. Script diatas akan melakukan pengecekan IP pada interface pppoe-out1 dan akan di cocokkan dengan IP pada hostname DynDNS. Jika terdapat perbedaan diantara keduanya, maka script akan melakukan update IP hostname DynDNS sesuai dengan IP pada interface pppoe-out1 saat script dijalankan.

Sumber : Wiki Mikrotik

3 thoughts on “Script Untuk Update IP DynDNS ( Mikrotik ROS 6.x )

  1. :2thumbup :2thumbup :2thumbup

    Mantab gan, kemarin dapet ane coba di 5.25 gak mau jalan scriptnya, yg ini barusan update ke 6.9 script diatas jalan lancar tanpa hambatan kayak di tol…
    :toast

Leave a Reply

Your email address will not be published. Required fields are marked *