Setting IGMP Proxy Pada Mikrotik untuk IndiHome dan UseeTV

Sebenernya lagi males nulis, jadi langsung poin2-nya saja ya.. Untuk gambar-gambar, nanti kalau gak malas di update…

Goal : Dengan menggunakan mikrotik, PC/Laptop/HP/Tablet maupun STB bisa akses internet IndiHome dan menonton IPTV UseeTV secara bersamaan dari jaringan kabel saja atau wifi saja. Bahasa lainnya mungkin :

Paralel akses Useetv di STB dan PC ataupun laptop dalam satu jaringan yang sama dengan akses internet Indihome

Ya seperti itulah pokoknya.. saya sendiri bingung memilih kalimat yang pas.. hehe.. 😀

Kondisi saat ini :

  • Koneksi internet IndiHome terhubung melalui Router mikrotik RB450G, dial pppoe dilakukan dari mikrotik dan dapat diakses PC/Laptop/HP/Tablet melalui kabel atau wifi, ONT set sebagai bridge.
  • STB hybrid UseeTV terkoneksi melalui 2 media, kabel dan wifi. Kabel terhubung dengan port IPTV UseeTV pada ONT untuk akses siaran TV, sedangkan wifi terhubung dengan router mikrotik RB450G untuk akses internet IndiHome buat youtube, browsing dan aplikasi lain yang membutuhkan koneksi internet

Kebutuhan :

  • paket instalasi multicast (download dari web mikrotik)
  • Routerboard Mikrotik (yg saya gunakan RB450G) dengan topologi :
    • port 2 : Gateway internet (pppoe) terhubung dengan port internet IndiHome pada ONT (punya saya port 3)
    • port 3 : Gateway multicast UseeTV terhubung dengan port IPTV UseeTV pada ONT (punya saya port 4)
    • port 4 : Jaringan Lokal (terhubung ke PC dan STB melalui kabel LAN
  •  PC dan STB hybrid UseeTV bawaan telkom (punya saya ZTE B760H)

Asumsi : saya asumsikan bahwa saat ini device anda sudah bisa terkoneksi dengan internet IndiHome secara lancar dengan menggunakan mikrotik sebagai router, karena dalam tulisan ini saya membatasi pada penambahan akses IPTV UseeTV kedalam jaringan yang sudah ada.

To Do :

  1. Install paket multicast pada routerboard mikrotik, caranya tinggal upload file multicast.npk ke routerboard, kemudian reboot
  2. login ke routerboard mikrotik menggunakan winbox dan buka terminal
  3. Ubah mac address port 3 (gateway UseeTV) menjadi mac address port wired STB UseeTV. Hal ini diperlukan karena telkom melakukan binding mac untuk bisa mengakses layanan TV dari UseeTV. Untuk mendapatkan mac address STB UseeTV anda bisa melihatnya pada menu setting > about pada STB. Untuk mengubah mac address port 3, ketikkan perintah :
    /interface ethernet set ether3-UseeTV mac=XX-XX-XX-XX-XX-XX
  4. Buat DHCP-Client dan DHCP Options pada interface ether3-UseeTV :
    /ip dhcp-client option add name=hostuseetv code=12 value="'ISIKAN-SERIALNUMBER-STB-USEETV'" 
    /ip dhcp-client add interface=ether3-UseeTV add-default-route=no dhcp-options=hostuseetv,clientid disabled=no
  5. Setting routing IGMP Proxy (bagian terpenting) :
    /routing igmp-proxy interface add interface=ether3-UseeTV upstream=yes alternative-subnets=0.0.0.0/0 threshold=1
    /routing igmp-proxy interface add interface=ether4-LAN threshold=1 upstream=no
    /routing igmp-proxy set quick-leave=yes query-interval=2m5s query-response-interval=1m40s
    
  6. Buat firewall filter untuk mengijinkan trafik IGMP dan UDP melewati router :
    /ip firewall filter add chain=input action=accept protocol=igmp in-interface=ether3-UseeTV log=no log-prefix=""
    /ip firewall filter add chain=input action=accept protocol=udp in-interface=ether3-UseeTV log=no log-prefix=""
    

    Pastikan kedua filter diatas berada diposisi paling atas.

  7. Buat static routing untuk trafik non multicast UseeTV dengan destinasi 10.0.0.0/8, Hal ini agar STB UseeTV bisa login dan mengakses EPG serta Video on Demand atau VoD dari server Telkom Indonesia (STB UseeTV akan berfungsi seperti biasa).
    /ip route add dst-address=10.0.0.0/8 gateway=10.21.0.1 type=unicast distance=1 scope=30 target-scope=10 disabled=no

    Sesuaikan gateway dengan Blok IP DHCP yang diperoleh pada ether3-UseeTV, saya memasukkan ip 10.21.0.1 sebagai gateway karena mendapatkan blok ip 10.21.0.0/20

  8. Tambahkan NAT masquerade untuk ether2 dan ether3
    /ip firewall nat add chain=srcnat out-interface=ether2-WAN2 action=masquerade
    /ip firewall nat add chain=srcnat out-interface=ether3-UseeTV action=masquerade
    
  9. Hubungkan port ether2 mikrotik dengan port internet IndiHome dan port ether3 mikrotik dengan port IPTV UseeTV menggunakan kabel UTP
  10. Cek DHCP client pada mikrotik, apakah sudah mendapatkan IP address dari server telkom.
  11. Silahkan anda coba menyalakan STB UseeTV hybrid, dan pilih salah satu, terkoneksi dengan wifi saja atau dengan kabel saja, matikan jaringan yang tidak digunakan. Jika semua setting benar, STB akan bisa login dan melihat siaran IPTV maupun TVoD UseeTV serta bisa mengakses Youtube maupun browsing.
  12. Untuk melakukan menonton Siaran IPTV UseeTV di PC, gunakan media player yang memungkinkan untuk melakukan streaming, saya biasa menggunakan KODI atau VLC. Untuk mendapatkan daftar Channel IPTV UseeTV, anda bisa menggunakan playlist m3u UseeTV berikut:
    https://pastebin.com/raw/z7biiam5

    (Playlist update : 23 Okt 2017, Playlist UseeTV lengkap dengan grup dan logo, tidak semua channel lancar dimainkan, sepertinya tergantung paket yang anda bayar 😀 )

Sekian dulu, mohon maaf jika ada yang salah. Silahkan tinggalkan komentar jika ada masukan dan saran.

 

Tambahan :

  • KODI : silahkan enable fitur Live TV dari menu setting, kemudian aktifkan add on PVR IPTV Simple Client, kemudian pilih configure dan masukkan URL Playlist UseeTV diatas pada alamat URL playlist. setelah berhasil buka menu LIVE TV dan pilih channel yang akan ditonton.
  • VLC : Buka menu Media > Open Network Stream.. dan masukkan url playlist UseeTV diatas.

183 thoughts on “Setting IGMP Proxy Pada Mikrotik untuk IndiHome dan UseeTV

  1. Widiyanto says:

    1 bulan yng lalu seting ini berhasil, tapi setelah sy ganti stb hybrid seting ini gk bisa, krn ip jaringan sy buat dhc tdk pernah mendapat ip 10.xx.xx. Akhirnya syng brigde antara lan yng muat port 4 dengan lan local internet, bisa, tapi makan resource

    • Saya di rumah juga pakai stb hybrid mas, dan konek hanya pakai kabel ke mikrotik tanpa konek wifi, stb memang dapat ip dari mikrotik 192.168. dan baik useetv maupun internet semua konek lancar. Stb bisa login, nonton live tv maupun tvod aman, dan youtube juga tanpa masalah. Untuk resources kalau hanya stb yg nonton useetv biasanya cpu di 20-30% tapi kalau tambah sama pc yg nonton useetv biasanya emang naik cpu usagenya.

  2. Diding Yudianto says:

    STB saya di rumah masih gak bisa dapat ip 10.x.x.x mas..
    topologi saya:
    GPON — Mikrotik (RB2011) — AP NSM5 — PBEM5 — Mikrotik (RB750GR3) — STB

    GPON port 4 ke RB2011 port 5 sudah tak setting igmp proxy dan berjalan lancar kalo untuk PC/VLC. tapi misal STB tak pasang langsung di Rb20011 port misal 6 kok gak dapat ip 10.x.x.x
    Apalagi untuk share via wireless seperti topologi diatas.

    Bulan lalu masih bisa untuk di share via wireless dengan hanya menggunakan Vlan. sekarang kok sudah gak bisa ya… apa sudah di lock dari telkom?

    • yg dapat ip 10.x.x.x memang harusnya RB2011, dan STB dapat ip dari RB2011, disini ada dua rouitng utnuk stb, pertama routing igmp/multicast dan routing untuk trafik lainnya yang fungsinya untuk akses login akun dan epg atau jadwal acara. sampai saat ini saya masih pakai topologi GPON – RB450G – STB/PC sebagaimana saya tulis diartikel diatas

      • Diding Yudianto says:

        RB2011 memang sudah dpt ip 10.x.x.x dan bisa dipakai kalo pakai PC/VLC mas.. tapi kalo STB dicolok ke port RB2011 tidak dapat ip 10.x.x.x
        ether RB2011 sudah di clone mac STB…
        kalo saran dari temen lain katanya cuma dibautkan dhcp server ether yg mengarah ke STB… juga tetep gak dpt ip 10.x.x.x
        gimana ya mas?

      • Yang dapat ip 10.x.x.x hanya port yg mengarah ke ont. Sedangkan stb akan dapat ip sesuai dhcp server yg dibuat di mikrotik

  3. Stephanus says:

    hallo, saya coba setting mikrotik utk useetv, sy ikuti langkah2nya, tapi sampai di IGMP proxy setelah diinput statusnya inactive…
    apa ada solusinya?
    trims sebelumnya

  4. gan terima kasih sebelumnya.
    saya sudha terapkan di kodi bejalan lancar. namun tidak berhasil di STB hybrid.
    saya mengunkan rb1100ahx2 dan router Os 6.40.5

    terima kasih

  5. asep says:

    maaf agan kalau disisi client yg di ap sama station nya bridge ko tidak bisa ya, ap dan st nya pakai ubnt

Leave a Reply

Your email address will not be published. Required fields are marked *